WinModems sous Linux 2.4

E-mail Print PDF

Quel est le problème?

Pour ceux qui n'ont pas encore rencontré ce problème,

voici une courte explication: Certains constructeurs de modems (3Com/USRobotics,

Lucent, xircom,...) on commencé il y a environ trois ans à

construire des modems PCI bon marché pour les PC desktop et les

laptops. Ces périphériques ne sont pas des "vrais" modems,

dans le sens où ils sont conçus avec moins e composants et

utilisent de façon plus importante le CPU de l'ordinateur dans lequel

ils sont montés. Sous windows 9x, le seul petit problème

était la nécéssité de posséder au minimum

un Pentium, les constructeurs fournissant le driver adéquat. Mais

pour les autres OS, impossible de les faire foctionner car ce driver étant

absent, le "modem" ne posséde pas de port COM dédicacé

comme les anciens modems sur carte ISA.

 

 

POUR QUELS MODEMS?

Le site de référence pour tous les problèmes de

compatibilité de modèles sous Linux est http://www.linmodems.org;

c'est aussi là que se trouve la mise à jour des différentes

solutions par constructeurs. Ce petit HOWTO se propose juste à aider

l'installation des modèles Lucent les plus courants, tels ceux des

portables Compaq Presario, dans le but de se connecter à Internet

via ppp, comme avec un modem "standard". Vous pouvez déterminer

votre modèle avec la commande lspci -v|more et lspci -nv.

 


SE FOURNIR LES DRIVERS ET LES DEPENDANCES

Pour commencer, vous devez savoir quelle version du kernel vous utilisez.

La commande uname -r aide bien. Ensuite, rendez-vous à http://walbran.org/sean/linux/stodolsk/ltmodem-5.78e.tar.gz.ftp://cs.anu.edu.au/pub/software/ppp/

ou en RPM à rpmfind.

Vous avez tout ce qu'il faut pour bien commencer.

 

 

et downloadez

Ce site est également une excellente source d'information pour tous

les modèles. Maintenant, vous devez mettre à jour ppp. Au

moment où j'écris ce howto, la version la plus récente

qui fonctionne bien avec le driver est la 2.4.0b2 (au minimum, il faut

la 2.2.13), disponibles soit en sources à

EXEMPLE: Le Lucent LT sur un Presario 1685 (Linux Kernel

2.4.1)

Décompessez l'archive ltmodem-5.78e.tar.gz dans un filesystem

Linux avec tar -xzvf ltmodem-5.78e.tar.gz, cd ltmodem-5.78e/, puis lisez

la 1ST-READ. Voici en raccourci ce qui y est expliqué et qui marche

bien:


• Essayez de loader le module précompilé pour un kernel 2.2

• avec: insmod -f ltmodem568.o . Si ca marche, vous avec maintenant un support

• du modem, sinon on continue...

• Lancez ./build_module (cela va construire le driver à partir du

• fichier ltmodem-5.78e.tar.gz lui-même contenu dans le package)

• Ensuite lancez ./ltinst (un output assez détailé suivra)

• lsmod vos indiquera que ltmodem est un module loadé et un ls -l

• /dev/modem devrait vous indiquer un pointeur vers /dev/ttyS14. Au prochain

• boot, vous verrez une ligne de plus décrivant votre modem Lucent....

• Installez pppd (rpm -Uvh ppp_archive.rpm ou tar -xzvf ppp_archive.tar.gz,

• suivis de ./configure; make; make install .

• Essayez de vous connecter à Internet avec votre dialer favori.

21/02/2001 Vincent Jamart

Last Updated ( Wednesday, 02 September 2009 23:11 )  
You are here: